搜文章
推荐 原创 视频 Java开发 iOS开发 前端开发 JavaScript开发 Android开发 PHP开发 数据库 开发工具 Python开发 Kotlin开发 Ruby开发 .NET开发 服务器运维 开放平台 架构师 大数据 云计算 人工智能 开发语言 其它开发
Lambda在线 > TensorFlow > 帮你了解 TensorFlow 构建和安装中的问题

帮你了解 TensorFlow 构建和安装中的问题

TensorFlow 2018-11-01

TensorFlow 在使用中, 一直在跟踪、记录构建问题以及安装问题。本文将列出使用 GitHub issues 和 Stack Overflow 跟踪、记录的构建和安装问题。


以下列表中将错误信息链接到了方案解决或讨论。 如发现未列出的安装或构建问题,请搜索 GitHub issues 和 Stack Overflow。 如果仍然找不到错误信息,请使用 tensorflow tag. 在 Stack Overflow 上进行询问。


GitHub issues 或 

Stack Overflow

错误信息

36159194

ImportError: libcudart.so.Version: 无法打开共享对象文件:

   没有对应的文件和目录

41991101

ImportError: libcudnn.Version: 无法打开共享对象文件:

   没有对应的文件和目录

36371137 and 

here

libprotobuf ERROR google/protobuf/src/google/protobuf/io/coded_stream.cc:207] A

   过大(超过 67108864 字节),协议消息被拒绝。

   要扩大限额(或禁用这些警告),请参阅

  CodedInputStream::SetTotalBytesLimit() in google/protobuf/io/coded_stream.h.

35252888

导入 tensorflow 时出错。 除非你使用 bazel,否则你不应该尝试从其源目录导入 tensorflow; 请退出 tensorflow 源代码树,重新启动你的 python 解释器。

33623453

IOError: [Errno 2] 没有对应的文件和目录:

  '/tmp/pip-o6Tpui-build/setup.py'

42006320

ImportError:Traceback(最近一次调用):

   文件 “... / tensorflow / core / framework / graph_pb2.py”,第 6 行,从 google.protobuf 导入描述符作为_descriptor

   ImportError:无法导入名称' descriptor '

35190574

SSLError: [SSL: CERTIFICATE_VERIFY_FAILED] 证书验证失败

42009190

安装收集的软件包:setuptools,protobuf,wheel,numpy,tensorflow

   找到现有安装:setuptools 1.1.6

   卸载 setuptools-1.1.6:

   例外:

  ...

   [Errno 1] 不允许操作:

  '/tmp/pip-a1DXRT-uninstall/.../lib/python/_markerlib'

36933958

安装收集的软件包:setuptools,protobuf,wheel,numpy,tensorflow

   找到现有安装:setuptools 1.1.6

   卸载 setuptools-1.1.6:

   例外:

  ...

   [Errno 1] 不允许操作:

   '/tmp/pip-a1DXRT-uninstall/System/Library/Frameworks/Python.framework/

   Versions/2.7/Extras/lib/python/_markerlib'

42006320

ImportError: Traceback (最近一次调用):

File ".../tensorflow/core/framework/graph_pb2.py", 第 6 行, 从 google.protobuf 导入描述符作为 _descriptor

ImportError: 无法导入名称'descriptor'

33623453

IOError: [Errno 2] 没有对应的文件和目录:

  '/tmp/pip-o6Tpui-build/setup.py'

35190574

SSLError: [SSL: CERTIFICATE_VERIFY_FAILED] 证书验证失败

42009190

安装收集的软件包:setuptools,protobuf,wheel,numpy,tensorflow

   找到现有安装:setuptools 1.1.6

   卸载 setuptools-1.1.6:

   例外:

  ...

   [Errno 1] 不允许操作:

  '/tmp/pip-a1DXRT-uninstall/.../lib/python/_markerlib'

33622019

ImportError: 没有名为 copyreg 的模块

37810228

在 pip 安装操作期间,系统返回:

OSError:[Errno 1] 不允许操作

33622842

导入 tensorflow 语句会触发错误,如下所示:

Traceback(最近一次调用):

  File "", line 1, in

  File "/usr/local/lib/python2.7/site-packages/tensorflow/__init__.py",

    第 4 行, 从 tensorflow.python 导入*

    ...

  文件 "/usr/local/lib/python2.7/site-packages/tensorflow/core/framework/tensor_shape_pb2.py", 第 22 行, 在

    serialized_pb=_b('\n,tensorflow/core/framework/tensor_shape.proto\x12\ntensorflow\"d\n\x10TensorShapeProto\x12-\n\x03\x64im\x18\x02

      \x03(\x0b\x32

      .tensorflow.TensorShapeProto.Dim\x1a!\n\x03\x44im\x12\x0c\n\x04size\x18\x01

      \x01(\x03\x12\x0c\n\x04name\x18\x02 \x01(\tb\x06proto3')

  TypeError: __init__() 得到了一个意外的关键字参数'syntax'

42075397

pip install 命令会触发以下错误:

...

您尚未同意 Xcode 许可协议,请运行 'xcodebuild -license'(用于用户级接受)或自 Terminal 窗口审查并同意 Xcode 的许可协议 'sudo xcodebuild -license'(用于系统范围内接受)。

...

   在 get_mathlib_info 中的文件 “numpy / core / setup.py”,第 653 行,引发 RuntimeError(“破坏的工具链:无法链接简单的C程序”)

 

RuntimeError:破坏的工具链:无法链接简单的 C 程序

41007279

[...\stream_executor\dso_loader.cc] 无法打开 CUDA 库 nvcuda.dll

41007279

[...\stream_executor\cuda\cuda_dnn.cc] 无法加载 cuDNN DSO

42006320

ImportError: Traceback (最近一次调用):

文件 "...\tensorflow\core\framework\graph_pb2.py", 第 6 行, 从 google.protobuf 导入描述符作为_descriptor

ImportError: 无法导入名称 'descriptor'

42011070

没有名为 "pywrap_tensorflow" 的模块

42217532

未知操作的OpKernel('op:“BestSplits”device_type:“CPU”'):BestSplits 

43134753

TensorFlow 库未编译,无法使用 SSE 指令

38896424

找不到能够满足需求张量流的版本

42006320

ImportError: Traceback (最近一次调用):

文件 ".../tensorflow/core/framework/graph_pb2.py", 第 6 行, 从 google.protobuf 导入描述符作为 _descriptor

ImportError: 无法导入名称 'descriptor'

33623453

IOError: [Errno 2] 没有对应的文件和目录:

  '/tmp/pip-o6Tpui-build/setup.py'

35190574

SSLError: [SSL: CERTIFICATE_VERIFY_FAILED] 证书验证失败

42009190

安装收集的软件包:setuptools,protobuf,wheel,numpy,tensorflow

   找到现有安装:setuptools 1.1.6

   卸载setuptools-1.1.6:

   例外:

  ...

   [Errno 1] 不允许操作:

  '/tmp/pip-a1DXRT-uninstall/.../lib/python/_markerlib'

33622019

ImportError: 没有名为 copyreg 的模块

37810228

在 pip 安装操作期间,系统返回:

OSError:[Errno 1] 不允许操作

33622842

导入 tensorflow 语句会触发错误,如下所示:

Traceback (最近一次调用):

  文件 "", 第 1 行,

文件 "/usr/local/lib/python2.7/site-packages/tensorflow/__init__.py",

    第 4 行, 从 tensorflow.python 导入*

    ...

 文件 "/usr/local/lib/python2.7/site-packages/tensorflow/core/framework/tensor_shape_pb2.py",第 22 行, in

    serialized_pb=_b('\n,tensorflow/core/framework/tensor_shape.proto\x12\ntensorflow\"d\n\x10TensorShapeProto\x12-\n\x03\x64im\x18\x02

      \x03(\x0b\x32

      .tensorflow.TensorShapeProto.Dim\x1a!\n\x03\x44im\x12\x0c\n\x04size\x18\x01

      \x01(\x03\x12\x0c\n\x04name\x18\x02 \x01(\tb\x06proto3')

  TypeError: __init__() 得到了一个意外的关键字参数'syntax'

41293077

W tensorflow/core/platform/cpu_feature_guard.cc:45] TensorFlow 库尚未编译为使用 SSE4.1 指令,但在您的机器上可以使用这些指令,这可以加快 CPU 计算。

42013316

ImportError: libcudart.so.8.0: 无法打开共享对象文件:

   没有对应的文件和目录

42013316

ImportError: libcudnn.5: 无法打开共享对象文件:

   没有相应的文件和目录

35953210

调用 `python` 或 `ipython` 会产生以下错误:

ImportError:无法导入名称 pywrap_tensorflow 

45276830

external/local_config_cc/BUILD:50:5: 在 apple_cc_toolchain 规则中

   @local_config_cc //:cc-compiler-darwin_x86_64:必须指定 Xcode 版本来使用 Apple CROSSTOOL。

47080760

未定义的引用 `cublasGemmEx@libcublas.so.9.0'

22512

ModuleNotFoundError: 没有名为 'tensorflow.python._pywrap_tensorflow_internal' 的模块

22512, 22794

ImportError: DLL 加载失败:找不到指定的模块

*注:点击 “阅读原文”,查看上方表格中蓝色文字对应的,错误信息的方案解决链接或讨论链接!



版权声明:本站内容全部来自于腾讯微信公众号,属第三方自助推荐收录。《帮你了解 TensorFlow 构建和安装中的问题》的版权归原作者「TensorFlow」所有,文章言论观点不代表Lambda在线的观点, Lambda在线不承担任何法律责任。如需删除可联系QQ:516101458

文章来源: 阅读原文

相关阅读

关注TensorFlow微信公众号

TensorFlow微信公众号:tensorflowers

TensorFlow

手机扫描上方二维码即可关注TensorFlow微信公众号

TensorFlow最新文章

精品公众号随机推荐